Can´t start the game (Fresh installed game)

  • I get the identical error.

    log_metro.txt is not found in My Documents, but in the root of F:\, which is the drive I installed the game onto. The contents are:
    Opened log in "userdata/log_metro.txt".
    Error: File "userdata/settings.script" not found!
    Error: Runtime error in "metro/scripts/init.script" at line 8: Internal error!
    Closed log in "userdata/log_metro.txt".

    the cited path, "userdata/" does not exist.

    Apparently, someone has made the rookie programmer mistake of hard-coding pathnames, so that if the game is not installed in the default location, it fails.

    Please advise, other than "install it in the default location".

  • That *was* the complete log_metro.txt file. Just those four lines, referencing a nonexistent pathname.

    This is the first time I have ever tried to start the game.

    I had tried to install the update, but reinstalling the original game without the update produces the same result.

  • Sorry, but i think you should do that.

    Could you give us some system states?

    If the game can't be installed in a different location, then the installer should warn of this and not offer the option to install elsewhere. However, all coding efforts should immediately be bent towards fixing such a lame goof as inability to install the game elsewhere, hopefully before colleagues learn about this foolish boner and start mocking.

    The only thing that should cause this is hardcoding pathnames, which, as I said earlier, is a rookie mistake that should make a coder feel ashamed of himself.

    So I'm not willing to install it in the default location, I don't have the disk space. I eagerly await the release of the embarrassed bugfix that allows the game to be installed where I choose, not where some coder chooses.

    I do not know what you mean by "system states", though. I'm happy to provide any information desired.

    Quote from eis_os

    Userdata is a virtual folder that points to your "My Documents" \ "Cities In Motion" Folder, if My Documents can't be written to CIM may crash will crash at the start.

    That much was pretty obvious. Equally obviously, the userdata folder, virtual or not, must be created, and is not being so created, witness the log file being created in the root of the installation drive, rather than where I was told I'd find it, somewhere in My Documents. Key here is the absence of userdata. It should exist *somewhere*, in the game directory or the root of the install drive, no matter where it actually points.

    If the program crashes at startup, then the crash should leave a record in the log stating why the program crashed, which would hopefully lead the user towards figuring out what to do about that. However, there's no indication in that log file, that My Documents is unwriteable -- only that a script file in userdata does not exist. It's a long leap from the latter to the former.

  • I happily run both CIM on different drives and different directories, I use a working copy on a different drive without any changes on the configs. So CIM doesn't need a real Installation, neither does it have hardcoded paths as far as I can tell.
    I am sure CIM uses the WinAPI call to detect where the Users Home Dir is. I guess this call fails in some way on your system, you should post these details in the Paradox Forum and tell the problem there the devs directly.

  • Ehh, never mind, there are too many games out there that work immediately and without all this hassle. I don't even know if I would like the game or not. It's not worth the fuss to find out.

    I don't see an option to close the thread/topic, so if that's needed, would someone please take care of it. I'm done.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!